Login failed

Phil Cryer phil at cryer.us
Wed Apr 12 17:19:20 CEST 2006


On Wed, April 12, 2006 10:04 am, Thomas Bruederli wrote:
> Phil Cryer wrote:
>> On Wed, April 12, 2006 9:35 am, Thomas Bruederli wrote:
>>> If session support is missing you would get an error right on your
>>> login
>>> screen (or in you logs). Does RoundCube give you any message like
>>> "Login
>>> failed" or just a blank page after your attempt to login?
>>
>> Yeah, it stays on the login page, but gives the 'Login failed' message
>> in
>> the red box at the top, just no error logs that I can find.
>
> It seems that the IMAP login succeeds but RC denies access because the
> user is not registered in the local users table and auto_create_user is
> set to FALSE. Set it on, and a user record will be created upon the
> first login.

Thanks for the suggestion Thomas, but no dice, and I suspect so since it
worked before.  Two things now, looking at my users table in my DB I have
two 'phil' entires:

|       1 | phil     | pepe.cryer.us |       | 2005-12-12 10:14:50 |
2006-04-11 12:25:02 | en_US    | a:5:{s:8:"timezone";d
r_html";b:1;s:10:"prettydate";b:1;s:10:"dst_active";b:1;} |

[...]
                                                          |
|       4 | phil     | localhost     |       | 2006-04-03 09:39:15 |
2006-04-03 09:39:15 | en_US    |

ah, notice that first one created last dec -- yeah, I'm old school with RC!

also, I turned log on to trace and tried to login and now I get:

IMAP Error: Authentication for phil failed (LOGIN): "a001 NO Plaintext
authentication disabled."

Warning: Cannot modify header information - headers already sent in
/usr/local/www/data-dist/roundcubemail-cvs/program/include/rcube_shared.inc
on line 121

So it looks like IMAP is the issue - I haven't messed with Dovecot
recently (afaik) but I'll take a look.  don't really understand the
doublespeak of :

NO Plaintext authentication disabled.

So plaintest auth is disabled...so only encrypted?  I'm running via SSL -
but perhaps within the server it's trying to login plain..hmm..

P


>
> ~Thomas
>>
>>> RoundCube does not store the user password in the local database. It
>>> uses the IMAP server as main authority.
>>
>> I thought that was the case...hmmm...again, I can login with Squirrel, I
>> can login with the same user via ssh, but not Roundcube.  I can't figure
>> out what the difference would be.
>>
>> P
>>
>>
>>> Regards,
>>> Thomas
>>>
>>> P.S. Please do not reply to an existing message when opening a new
>>> thread.
>>>
>>> Phil Cryer wrote:
>>>> This is strange, I rebooted my server yesterday, now I can't login to
>>>> Roundcube.  Fails on CVS version, plus the last stable release,
>>>> whereas
>>>> they worked fine before the reboot.  The annoying thing is 1) I get no
>>>> errors at all in my logs and 2) I can still login as normal via
>>>> Squirrelmail on the same box.  Apache logs say:
>>>>
>>>> 199.249.176.251 - - [12/Apr/2006:09:16:50 -0500] "GET /roundcubemail/
>>>> HTTP/1.1" 200 1843
>>>> 199.249.176.251 - - [12/Apr/2006:09:16:51 -0500] "POST /roundcubemail/
>>>> HTTP/1.1" 200 1942
>>>>
>>>> And that's it.  This sounds like my friend's issue with PHP compiled
>>>> w/o
>>>> Session support, but I would expect to see errors in that case.  How
>>>> can
>>>> I
>>>> query PHP to see if this is included, or what else could be causing
>>>> this?
>>>> I've forgotten, does RC look to mysql for authentication for the user?
>>>>
>>>> P
>>>
>>>
>>
>>
>


-- 
http://fak3r.com - you don't have to kick it





More information about the Dev mailing list