Single mime part email

Robin Elfrink elfrink at introweb.nl
Wed Nov 22 14:09:21 CET 2006


Hi,


I have an email with a single mime part which looks like this
(irrelevant headers removed):


===========================================
Content-class: urn:content-classes:message
X-MS-Has-Attach: yes
MIME-Version: 1.0
Content-Type: application/vnd.ms-excel;
	name="Bureau CVL 06-10.xls"
Content-Transfer-Encoding: base64
Content-Description: Bureau CVL 06-10.xls
Content-Disposition: attachment;
	filename="Bureau CVL 06-10.xls"
X-MS-TNEF-Correlator:
X-MimeOLE: Produced By Microsoft Exchange V6.5.7226.0

0M8R4KGxGuEAAAAAAAAAAAAAAAAAAAAAPgADAP7/CQAGAAAAAAAAAAAAAAABAAAAAQAAAAAAAAAA
EAAAEgAAAAEAAAD+////AAAAAAAAAAD/////////////////////////////////////////////
////////////////////////////////////////////////////////////////////////////
////////////////////////////////////////////////////////////////////////////
////////////////////////////////////////////////////////////////////////////
////////////////////////////////////////////////////////////////////////////
etc...
===========================================


So basically it's a single mime part email. This usually does not happen
with _normal_ MUA's, but MS Exchange seems not to care what the world
thinks.

Anyway, I fixed this one with attached patch, but I am not sure about
any impact with other emails with or without attachments. I looked at
about 50 different emails with and without attachments, from normal
users and MS users, and I found no error so far.

Would you people please take a look and see if this is fine?



Robin
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: mime-parts.patch
URL: <http://lists.roundcube.net/pipermail/dev/attachments/20061122/e4fa99ac/attachment.ksh>


More information about the Dev mailing list