[RCD] "Supported" browsers

chasd chasd at silveroaks.com
Wed Nov 14 16:31:48 CET 2007


At the link
<http://trac.roundcube.net/wiki/Howto_Requirements>

Only this is mentioned for browser requirements :

     * Javascript enabled
     * Accept cookies
     * Support for XMLHttpRequest

Since I have some users on old or odd platforms, I was wondering if  
there should be a list of "tested" browsers.
This may be incorrect, but from reading the Dev mail list, it seems  
the main developers test on the major browsers.

IMHO it seems that RoundCube is "tested" on

IE 6 ( Win XP ) and 7 ( Win XP and Vista )
Safari 2 ( OS X 10.4.x ) and 3 ( OS X 10.4.x and 10.5.x, Win XP, Vista )
Firefox 2 ( Win XP, OS X 10.4.x )

Should that specifically be mentioned in the browser requirements ?
Are there others that are smoketested by Devs ?

If other browsers are known to work by users, those could be added to  
a "reported to work" section, so there is not an implication those  
browsers are regularly used by the Devs.
I think Opera 9 is used by others on the Dev list, and I use Camino,  
although always the very latest release.

Maybe there should also be a "known not to work" section so bugs  
don't get filed that will likely never be addressed ?
I realize that if IE 6 works, you have covered almost every Windows  
user, but the Mac platform has had many different browsers available  
for it, and many different versions of those. Sadly each with  
differing capabilities as far as HTML, CSS, and ECMAScript support.  
Such browsers would be Safari 1.2x or 1.0.x ( OS X 10.3.x, 10.2.x ),  
Firefox 1.0.x or 1.5.x, Mozilla Suite ( Mac OS 9 ), IE 4.x ( Mac OS  
9 ), iCab, etc.


Charles Dostale
System Admin - Silver Oaks Communications
http://www.silveroaks.com/
824 17th Street, Moline  IL  61265

_______________________________________________
List info: http://lists.roundcube.net/dev/



More information about the Dev mailing list