[RCD] complete URL in message body

Eric Stadtherr estadtherr at gmail.com
Mon Nov 17 17:48:45 CET 2008


Along those same lines, I had to make a similar change lately to allow some
recent messages to be displayed. In my case, the offending element was a
"<broadcast>" element that contained the entire HTML part of the MIME
message. I had to add 'broadcast' to the 'html_elements' array (in
program/steps/mail/func.inc::rcmail_print_body()).

I'm unfamiliar with a "broadcast" element, so I'm not surprised that
washtml didn't like it. However, it seems we're running into cases where
washtml might be too restrictive for our display purposes. Rather than
continuing to add these special cases to our code, can anyone think of a
more generic solution to allow these kinds of unusual but benign elements
to pass through the washing process?



On Mon, 17 Nov 2008 08:05:03 +0100, Viktor Balogh
<viktor.balogh at vrphoto.hu>
wrote:
> OK, I've found out that in the original message in my mail folder
> there are some wbr tags. After I've enabled wbr in washtml.php 
> it works perfectly. 
> 
> Thanks a lot!
> 
> 
> On Mon, 17 Nov 2008 07:45:11 +0100, Viktor Balogh
> <viktor.balogh at vrphoto.hu>
> wrote:
>> I think it's not about a WBR tag in HTML, at least the original message
>> has'nt wbr in it.
>> I've enclosed an excerpt from the html source what I get in the browser
> in
>> Roundcube.
>> 
>> The original email can you see at
>> <http://tech.groups.yahoo.com/group/PanoToolsNG/message/24665>,
>> there you can see the whole URL in the message body.
>> 
>> As you can see, both the link "java.sun.com" and "erik-krause.de" were
>> shortened to the first segment "java." and "erik-".
>> 
>> Any idea?
>> 
>> On Sun, 16 Nov 2008 19:20:55 +0100, "A.L.E.C" <alec at alec.pl> wrote:
>>> Viktor Balogh wrote:
>>>> 
>>>> Hi all,
>>>> 
>>>> I've observed that in some mails the URL will be cutted,
>>>> and only the first segment will be displayed.
>>>> The delimiters can be "." or "-".
>>>> Why is this happening? Anyway, the link works 
>>>> but it annoys me as I don't see where the link goes.
>>>> 
>>>> In the page source I see always:
>>>> 
>>>> "<!-- wbr not allowed -->"
>>> 
>>> Show as sample source code, please.
>>> 
>>>> What is this wbr?
>>> 
>>> An WBR tag? It's currently not allowed in washtml class
>>> 
>>>> I wanted to alter the php source to disable this thing,
>>>> but I couldn't find it. Please help me!
>>> 
>>> see lib/washtml.php. Try to add 'wbr' in $html_elements array.
>> 
>> -- 
>> *********************************
>> Visit my panoramic photoblog!
>> http://vrphoto.hu
>> 
>> 
>>  --- 8< --- detachments --- 8< ---
>>  The following attachments have been detached and are available for
>>  viewing.
>>   http://detached.gigo.com/rc/pH/cH86dE7P/source.txt
>>  Only click these links if you trust the sender, as well as this
message.
>>  --- 8< --- detachments --- 8< ---

-- 
Eric Stadtherr
estadtherr at gmail.com
_______________________________________________
List info: http://lists.roundcube.net/dev/



More information about the Dev mailing list