[RCD] email won't be displayed

Viktor Balogh viktor.balogh at vrphoto.hu
Tue Mar 16 13:45:29 CET 2010


Hi list,

First of all, I don't know if it is a known bug or not, I didn't have the
time to run through all the bug reports for RC. I regularly get some
newsletters from  a list, and some mail's contents aren't visible, only a
blank whiteness and nothing else. This appears around weekly once, though
it cannot be pre-determined, it seems to appear randomly.

>From the source code (it is a HTML email):

#############################################################

<div id="remote-objects-message">To protect your privacy, remote images
are blocked in this message. <a href="#loadimages"
onclick="rcmail.command('load-images')">Display images</a></div>

<div id="messagebody"><div class="message-htmlpart"><!-- html ignored
--><!-- head ignored --><!-- meta ignored --></div>
</div>

</div>
</div>

<div id="messagecountbar" class="pagenav">
  <a class="buttonPas lastpage" title="Show the last message"
id="rcmbtn117" href="#" onclick="return
rcmail.command('lastmessage','',this)"> </a>

  <a class="buttonPas nextpage" title="Show the next message"
id="rcmbtn118" href="#" onclick="return
rcmail.command('nextmessage','',this)"> </a>
  <span style="padding:0 1em 0 1em; float:right"
id="rcmcountdisplay">Message 14 of 160</span>
  <a class="buttonPas prevpage" title="Show the previous message"
id="rcmbtn119" href="#" onclick="return
rcmail.command('previousmessage','',this)"> </a>
  <a class="buttonPas firstpage" title="Show the first message"
id="rcmbtn120" href="#" onclick="return
rcmail.command('firstmessage','',this)"> </a>
</div>
</div>

<script type="text/javascript">
    var mailviewsplitv = new rcube_splitter({id:'mailviewsplitterv', p1:
'mailboxlist-container', p2: 'messageframe', orientation: 'v', relative:
true, start: 165});
    rcmail.add_onload('mailviewsplitv.init()');
</script>

<script type="text/javascript">
/* <![CDATA[ */

$(document).ready(function(){ rcmail.init(); });
/* ]]> */
</script>

#############################################################

So, I think at least the text "To protect your privacy..." should be
visible when nothing else. I tried it with Firefox 3.5.8 and IE 7.0,
nothing was displayed just a white blank page. If you need some more info
then let me know. Please help me to analyze and solve this bug...

Regards,
Viktor

-- 

Visit my panoramic photoblog!

http://vrphoto.hu
Spherical panoramas by Viktor Balogh
_______________________________________________
List info: http://lists.roundcube.net/dev/



More information about the Dev mailing list