[RCD] hook/event names unification

A.L.E.C alec at alec.pl
Fri May 21 10:28:51 CEST 2010


I know this will break backward compatybility, but I think we should 
unify names of hooks/events. So, what need to be changed:

Old Name                New Name
-------------------------------------
Events:
insertgroup		group_add
updategroup		group_update
removegroup		group_delete
insertrow		message_add
listupdate		list_update
selectfolder		folder_select
Hooks:
create_user		user_create
kill_session		session_destroy
upload_attachment	attachment_upload
save_attachment		attachment_save
outgoing_message_headers message_outgoing_headers
outgoing_message_body	message_outgoing_body
address_sources		addressbooks_list
get_address_book	addressbook_get
create_contact		contact_create
save_contact		contact_save
delete_contact		contact_delete
manage_folders		folders_list
save_preferences	settings_save
user_preferences	settings_list
list_prefs_sections	settings_sections_list
list_identities		identities_list
create_identity		identity_create
save_identity		identity_save

-- 
Aleksander 'A.L.E.C' Machniak http://alec.pl gg:2275252
LAN Management System Developer http://lms.org.pl
Roundcube Webmail Developer http://roundcube.net
_______________________________________________
List info: http://lists.roundcube.net/dev/



More information about the Dev mailing list