[RCD] Fwd: Re: r4397

A.L.E.C alec at alec.pl
Fri Jan 7 09:48:00 CET 2011

Here's my discussion with Thomas about r4397 change. What do you think?
Another example of this "issue" is when you move a lot of messages to
some folder and when you select other folder before the copying
finishes. It this case "Copying messages..." is replaced by "Loading..."
(before the copying finishes). So, I see two solutions:
1) revert the change
2) use "Loading..." everywhere instead of specific message like
"Copying..." etc.

A.L.E.C wrote:
> On Thu,  6 Jan 2011 07:49:06 -0600, trac at roundcube.net wrote:
>> Author: thomasb
>> Date: 2011-01-06 07:49:06 -0600 (Thu, 06 Jan 2011)
>> New Revision: 4397
>>    trunk/roundcubemail/program/js/app.js
>> Log:
>> Only display one loading message at once
> I fill this is wrong. For example, when you click "check recent" loading
> message with "checkingmail" label is displayed. Then, before this message
> disapears, open a message. This makes that "checkingmail" message is
> replaced by "loading" message. I'd like to see both. That's why the whole
> label was used as an index of this.messages hash.
I just made the experience that a confirmation message and two loading
messages cluttered my screen. From a user perspecitive it's important to
see all confirmations but if something is loading it's not necessarily
important to me what is loaded. I just need to know that there's something
going on and that I have to wait.

Not sure if my arguments can convice you, it's just my opinion...
Feel free to ask more people about this topic.


Aleksander 'A.L.E.C' Machniak
LAN Management System Developer [http://lms.org.pl]
Roundcube Webmail Developer  [http://roundcube.net]
PGP: 19359DC1 @@ GG: 2275252 @@ WWW: http://alec.pl
List info: http://lists.roundcube.net/dev/

More information about the Dev mailing list