[RCD] rcmail_config["forward_attachment"] = false not working?

Rob Sheldon rob at associatedtechs.com
Wed Feb 8 22:57:52 CET 2012


This might be some kind of an issue with user preferences; I edited the 
preferences stored in the users table under my username and removed the 
forward_attachment item, and everything worked correctly after that.

Dunno if there's supposed to be some kind of per-user way to configure 
that behavior or not. I can't find it.

Thanks,

- R.

On Feb 08 2012 09:43 am, Rob Sheldon wrote:
> In 0.7.0 and 0.7.1, I can't seem to get Roundcube to disable the
> forward-as-attachment setting. I tried tracking down the cause but
> unfortunately I'm not familiar enough with how Roundcube passes 
> settings
> between PHP and Javascript to figure this one out in a reasonable 
> amount
> of time.
>
> If I hardcode a "$OUTPUT->set_env('forward_attachment', false);" into
> program/steps/mail/show.inc, or comment out the existing code for it, 
> it
> doesn't seem to affect the behavior of the JS in the interface. If I
> pull up a developer console in the browser and set
> rcmail.env.forward_attachment to false, then everything's groovy. 
> It's
> set to true somewhere during page/message load, but for the life of 
> me I
> can't figure out where or how or why.
>
> Anybody else seeing this? Any hints on tracking this down?
>
> Thanks,
>
> - R.

-- 
[__ Robert Sheldon
[__ Founder, No Problem
[__ Information technology support and services
[__ (530) 575-0278
[__ "You must be the change you wish to see in the world." -- Mahatma 
Gandhi
_______________________________________________
List info: http://lists.roundcube.net/dev/
BT/aba52c80



More information about the Dev mailing list