[RCD] Roundcube deletes leading blanks upon sending - but why??

Michael Heydekamp listuser at freexp.de
Mon Apr 22 22:03:40 CEST 2013


Am 22.04.2013 10:28, schrieb A.L.E.C:
> On 04/21/2013 10:54 PM, Michael Heydekamp wrote:
> 
>>> SERVICE(S):
>>> What is requested               Status
>>> ---------------------------------------------------------------------------------
>>> GEORGIA                         PERMIT 004/0025-13
>>>                                 ENTRY / EXIT: IDLER / ADEKI
>>
>> Please note that there are just blanks between "GEORGIA" and "PERMIT" (no
>> Tabs 09d or the like, but such scenarios still need to be tested as well).
>>
>> This is being sent:
>>
>>> SERVICE(S):
>>> What is requested               Status
>>> ---------------------------------------------------------------------------------
>>> GEORGIA
>>>                         PERMIT 004/0025-13
>>>                                 ENTRY / EXIT: IDLER / ADEKI
>>
>> RC inserts an LF right after "GEORGIA".
> 
> Fixed. It looks that even the code from Zend Framework I used could not
> handle such case properly ;) We're going to have the best text wrapping
> method ever thanks to your "help" ;)

I can confirm, that:

1) Leading blanks are not deleted anymore.
2) The issue described above has been fixed.
3) Another issue (most likely pretty much the same as 2) above) I
encountered today has been fixed as well:

I composed (without quote chars):

> Test.
> -----------------------------------------------------------------------------------
> 
> Best regards,
> -- 
> Michael Heydekamp

This has been sent this way:

> Test.
> -----------------------------------------------------------------------------------
> 
> Best
> regards,
> -- 
> Michael Heydekamp

So an unintentional LF between "Best" and "regards". This is fixed as well
now.

This "Zend Framework" looks somewhat insane to me. But may I ask: I didn't
have all the issues above before (in 0.9), how and why did they make their
way into 1.0-git? There were still some wordwrap issues in 0.9, yes, but not
the ones we're currently talking about. So there must have been significant
changes between 0.9 and 1.0 which did escape me.

I believe to have seen even more issues in the meantime, but I need to do
more testing before I'll report them.

And with regards to the "help": Believe me, if I'd be capable of coding my
own wordwrap(), I'd do it. But I'm not, so I can just report the issues I'm
encountering.

To be continued...

Cheers,
-- 
Michael Heydekamp
Co-Admin freexp.de
Düsseldorf/Germany


More information about the dev mailing list