[RCD] Debugging

Guido Berhoerster guido+roundcube.net at berhoerster.name
Mon Mar 11 10:28:32 CET 2013


When trying to log into a fresh roundcube 0.9rc installation I'm
always getting an "Invalid request! No data was saved." error.
How can I debug what is going on here?
I have already enabled logging with the following settings:

$rcmail_config['debug_level'] = 1;
$rcmail_config['log_driver'] = 'file';
$rcmail_config['smtp_log'] = true;
$rcmail_config['log_logins'] = true;
$rcmail_config['log_session'] = true;
$rcmail_config['sql_debug'] = true;
$rcmail_config['imap_debug'] = true;
$rcmail_config['ldap_debug'] = true;
$rcmail_config['smtp_debug'] = true;

The only this that is logged is the following to the sql log (I'm
using sqlite):

[11-Mar-2013 10:15:09 +0100]: [1] SELECT vars, ip, changed FROM session WHERE sess_id = 'f323pb6b4mnu9gbkl2datv5783';
[11-Mar-2013 10:15:09 +0100]: [2] DELETE FROM session WHERE sess_id = 'f323pb6b4mnu9gbkl2datv5783';
[11-Mar-2013 10:15:09 +0100]: [3] DELETE FROM session WHERE sess_id = 'f323pb6b4mnu9gbkl2datv5783';
[11-Mar-2013 10:15:09 +0100]: [4] INSERT INTO session (sess_id, vars, ip, created, changed) VALUES ('f323pb6b4mnu9gbkl2datv5783', 'bGFuZ3VhZ2V8czo1OiJlbl9VUyI7dGVtcHxiOjE7c2tpbnxzOjU6ImxhcnJ5Ijs=', '10.0.4.100', '2013-03-11 10:15:09', '2013-03-11 10:15:09');

Is there any way to get more detailed logs so I can see what the
actual problem is? I've already tried raising debug_level to 8 to
no avail.
-- 
Guido Berhoerster


More information about the dev mailing list