[RCD] plugins.roundcube.net ready for testing

Thomas Bruederli thomas at roundcube.net
Wed May 1 15:12:53 CEST 2013


Phil Weir wrote:
> Hi,
> 
> I think I've followed the instructions on the front of plugins.roundcube.net
> correctly. My composer.json file is attached, composer version:
> 
> phil at ghost:<rc root># php composer.phar -V
> Composer version 823ca21e6cf9c4f4c7a13060e678e7ad32cc40a4
> 
> 
> But when I run composer it fails....
> 
> phil at ghost:<rc root># php composer.phar install
> Loading composer repositories with package information
> Installing dependencies
>   - Installing roundcube/plugin-installer (dev-master 0.1.2)
>     Cloning 0.1.2
> 
> PHP Fatal error:  Class 'Roundcube\Composer\PluginInstaller' not found in
> phar://<rc root>/composer.phar/src/Composer/Installer/InstallerInstaller.php
> on line 101
> 
> I'm running PHP 5.3 and it does create the plugin-installer files in <rc
> root>/vendor/roundcube/plugin-installer/src/RoundCube/Composer/PluginInstall
> er.php.
> 
> Does anyone know what I might have done wrong?

Never had that issue and I'm also unable to reproduce. Seems like an
autoloading issue. What version of PHP are you using?

~Thomas



More information about the dev mailing list