[RCD] Compatibility problems with contextmenu plugin (was: contextmenu plugin new version - cal for testers and feedback)

Phil Weir roundcube at tehinterweb.co.uk
Sat May 10 08:33:36 CEST 2014


> BUT: It does NOT work with RC-beta, no matter which OS and which 
> browser (so
> not even with Win7 and FF 27):

Roundcube 1.1-git includes new multi-folder search functionality. To 
achieve this the way that they message list works was changed and so 
plugins which us it had to be changed to. There are new functions needed 
to find the message UID now. The git-master version of the contextmenu 
plugin uses these new functions, obviously the 2.0 release cannot since 
they do not exist in Roundcube 1.0. So for the two different versions of 
Roundcube you need different versions of the plugin.

> Another issue: The version number of contexmenu isn't shown unter
> Settings/About - apparently because there's no package.xml which does
> contain the version number...? How to solve this?

At the moment the version information needed for the About screen is 
added when you download via the composer system (plugins.roundcube.net). 
The composer system has a few good advantages like making updates easier 
and making sure you get the right version of a plugin for your version 
of Roundcube ... ;). BTW it is my understanding that having both a 
composer.json file and a package.xml file is wrong. The package.xml file 
will never be used and plugin devs can add version information into 
their composer.json file if they want.


More information about the dev mailing list