RoundCube broken with php 5.2.0

Spil Oss spil.oss at googlemail.com
Fri Feb 2 20:40:50 CET 2007


Hi All,

Finally I found out what broke my php5.2/roundcube, it was my make
environment in FreeBSD. My kernel and userland were NO_INET6, but I
didn't have WITHOUT_IPV6 set for my ports.
After I set WITHOUT_IPV6 it works fine!

Kind regards,

Spil

Hope this helps some other people!

On 05/12/06, Spil Oss <spil.oss at googlemail.com> wrote:
> Working order of extensions.ini is welcome!
>
> Kind regards,
>
> Spil
>
> On 02/12/06, Phil Cryer <phil at cryer.us> wrote:
> > Ok, I'm on 5.2 with Suhosin and eAccel working fine:
> >
> > [20:15:53] [root at chavez /root]# php --version
> > PHP 5.2.0 with Suhosin-Patch 0.9.6.2 (cli) (built: Nov 17 2006 10:58:01)
> > Copyright (c) 1997-2006 The PHP Group
> > Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend Technologies
> >     with eAccelerator v0.9.5, Copyright (c) 2004-2006 eAccelerator, by
> > eAccelerator
> >
> > Let me know if you want to see my php.ini or anything else.
> >
> > P
> >
> >
> > On 12/1/06, Spil Oss <spil.oss at googlemail.com> wrote:
> > > Hi Phil,
> > >
> > > Yes, I've tried to run without suhosin and eaccelator, but no luck.
> > >
> > > There are reports on this list indicating that the order of loading
> > > extensions is important, I'll be trying that next!
> > >
> > > Spil.
> > >
> > > PS *light* I had a non-crashing debug-build of php 5.2, perhaps the
> > > extensions.ini in there is a winner!
> > >
> > > On 20/11/06, Phil Cryer <phil at cryer.us> wrote:
> > > > In that ticket, notice:
> > > >
> > > > " PHP 5.2.0 with Suhosin-Patch 0.9.6.1 "
> > > >
> > > > I just rebuilt PHP due to a server rebuild (so I haven't tested RC yet)
> > but
> > > > I noticed it included that hardening patch (suhosin) this time...have
> > you
> > > > tried building w/o that?  If running freebsd just do a 'make config' in
> > the
> > > > php5.2 port dir to turn it 'off'.  I'll try this, but won't be for a few
> > > > days.  Yeah, I flubbed when trying to move a set of RAID1 drives from
> > one
> > > > server to another...
> > > >
> > > > P
> > > >
> > > >
> > > > On 11/20/06, Spil Oss <spil.oss at googlemail.com> wrote:
> > > > > Seems I'm not the only one with php 5.2.0 / eaccelerator problems...
> > > > >
> > > > > https://www.eaccelerator.net/ticket/207#preview
> > > > >
> > > > > Unfortunately no-one seems to have picked it up yet....
> > > > >
> > > > > Spil.
> > > > >
> > > > > On 09/11/06, Spil Oss <spil.oss at googlemail.com> wrote:
> > > > > > Hi All,
> > > > > >
> > > > > > Now running php compiled with --enable-debug so I could create a
> > dump
> > > > > > backtrace, and guess what, RoundCube is no longer segfaulting on
> > > > > > RoundCube.
> > > > > >
> > > > > > Anyone able to explain this behaviour?
> > > > > >
> > > > > > Kind regards,
> > > > > >
> > > > > > Spil
> > > > > >
> > > > > > On 09/11/06, Spil Oss < spil.oss at googlemail.com> wrote:
> > > > > > > No such luck....
> > > > > > >
> > > > > > > Ran portupgrade -rf php5 and still rouncube fails. If anyone has
> > any
> > > > > > > suggestions on how to make roundcube more verbose, I'm open for
> > > > > > > suggestions!
> > > > > > >
> > > > > > > Kind regards,
> > > > > > >
> > > > > > > Spil.
> > > > > > >
> > > > > > > On 08/11/06, Spil Oss < spil.oss at googlemail.com> wrote:
> > > > > > > > Hi All,
> > > > > > > >
> > > > > > > > Just pulled the 20061108 snapshot and now succesfully able to
> > build
> > > > > > > > pear again (open_basedir restriction gave me headaches). Will
> > try
> > > > > > > > again, also rebuilding PEAR.
> > > > > > > >
> > > > > > > > As always, determined to make pigs fly!
> > > > > > > >
> > > > > > > > Kind regards,
> > > > > > > >
> > > > > > > > Spil.
> > > > > > > >
> > > > > > > > On 08/11/06, Moritz < mo at agrav.org> wrote:
> > > > > > > > > Spil Oss wrote:
> > > > > > > > > > Reverting back to 5.1.6 solved my problem.
> > > > > > > > >
> > > > > > > > > > Mind you, there are reports of people succesfully running
> > > > roundcube on
> > > > > > > > > > php 5.2.0, so you might try it on a test-box and then deploy
> > if
> > > > > > > > > > succesful.
> > > > > > > > > > There must be something special with my setup that breaks
> > > > roundcube....
> > > > > > > > >
> > > > > > > > > I can confirm this. I have roundcube running on PHP 5.2.0 and
> > it
> > > > seems
> > > > > > > > > to work fine.
> > > > > > > > >
> > > > > > > > > My system details:
> > > > > > > > >
> > > > > > > > >  - roundcube v0.1-beta2
> > > > > > > > >  - PHP 5.2.0-0.dotdeb.1 with Suhosin-Patch 0.9.6
> > > > > > > > >  - Debian 3.1
> > > > > > > > >
> > > > > > > > > > Kind regards,
> > > > > > > > > >
> > > > > > > > > > Spil.
> > > > > > > > >
> > > > > > > > > Regards,
> > > > > > > > > --
> > > > > > > > > Moritz
> > > > > > > > >
> > > > > > > > > mo at agrav.org | mo.agrav.org | luna.agrav.org/~mo
> > > > > > > > >
> > > > > > > > > Get my GPG key fingerprint here:
> > > > > > > > > https://luna.agrav.org/~mo/gpg/
> > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > > >
> > > > >
> > > >
> > > >
> > > >
> > > > --
> > > > "Without music, life would be a mistake" - Friedrich Nietzsche
> > >
> > >
> >
> >
> >
> > --
> >
> > "Without music, life would be a mistake" - Friedrich Nietzsche
>




More information about the users mailing list