[RCU] Still trying to get virtuser_file to work in current SVN

Claudio Kuenzler napsty at gmail.com
Wed Jun 30 14:09:22 CEST 2010


Hi Arne,

I tried it as well, just to test the virtuser_file plugin functionality.
It must have something to do with your domain configuration I suppose. My
virtuser file looks similar to yours (standard virtual users file):

mail1 at example.com web230p1
test at example.com web230p1
bla at example2.com web24p1
flubber at example2.com web24p1

IMAP server set as local: Test with web230p1 works fine. This added the
identities of both e-mail addresses.
Then I changed the IMAP server address to a remote one. Test with web24p1
works fine as well. It added the identities of both example2.com addresses.

Stupid question: Is Roundcube able to read the virtuser file where it is
located? Maybe you've set up an open_basedir or something that might prevent
it? I ran into a problem like this on my very first install.

And another stupid question: Did you add the following variable into your
main.inc.php ?
$rcmail_config['virtuser_file'] = '/path/to/roundcube/virtuserfile';

cheers,
Claudio


On Fri, Jun 25, 2010 at 8:44 PM, Arne Berglund <aberglund at lesd.k12.or.us>wrote:

> On Thu, 24 Jun 2010 15:43:04 -0700, Arne Berglund <
> aberglund at lesd.k12.or.us> wrote:
>
> Still beating my head against the wall on getting virtuser_file to work. I
> have checked out a new SVN copy (currently 3785), built a brand new
> database, and the only plugin enabled is virtuser_file. No luck. I have the
> plugin set to pull from a local file on the same server as RC is running.
> Any help would be greatly appreciated.
>
> --
>
>  I have still been unable to get the virtuser_file plugin to work, and I
> really need to have this functionality from *SOMEWHERE*, if not here. I am
> no longer certain that I have EVER had this working, as I now believe that
> when I thought I worked I may have been pulling data from
> squirrelmail_usercopy instead. That is fine for existing user migrations,
> but I need a mechanism to insert the correct email address for new users
> (who never used squirrelmail) going forward.
>
> Here is my situation - RC connects to an external IMAP server
> (sendmail/dovecot). We have 14 different domains on that single server, but
> all use a shared namespace. The domain of the IMAP server is not the same as
> any of the 14 domains in use, and because of the shared namespace, many of
> the email addresses in use do not share the username.
>
> Example:
>
>    - The server is at hidden.domain.net
>    - My username (limited to 8 chars) is aberglun
>    - My email address is]arne.berglund at public.domain1.net
>
> But when logging in for the first time, RC constructs the email address in
> my identity as aberglun at hidden.domain.net.
>
> I have a copy of the sendmail virtusertable flat file on the RC server, and
> have pointed the plugin at that file. The file is in the format of:
>
> arne.berglund at public.domain1.net  aberglun
>
> I can find no evidence that the virtuser lookup is even happening. But
> can't say for certain that it's not, either.
>
> Is it possible that the virtuser_file plugin can't be used for my
> particular scenario?
>
> --
> Arne Berglund
> System Administrator, Internet Services
> Lane Education Service District
> Eugene, OR
> 541.461.8343
> ____________
>
>
> _______________________________________________
> List info: http://lists.roundcube.net/users/
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.roundcube.net/pipermail/users/attachments/20100630/205e257b/attachment-0001.html>
-------------- next part --------------
_______________________________________________
List info: http://lists.roundcube.net/users/


More information about the users mailing list