[RCU] Session timeouts all over the place

Arne Berglund aberglund at lesd.k12.or.us
Wed May 2 01:21:31 CEST 2012


On 05/01/2012 15:55, Michael Heydekamp wrote:
>
> Serious question: Do you have several hundred users on your server 
> and you
> have RC just installed but probably not widely used, because your 
> several
> hundred users are mainly or exclusively using their local mail client 
> (as
> most of the subscribers to this list, given the "User-Agent" and 
> "X-Mailer"
> headers I'm seeing)...? Or are these several hundred users really 
> using RC
> only and all day?

No, I have over 2,000 accounts total, 1600+ are webmail users, and 
typically 4-500 connected at any given time during the work day. We 
don't encourage local clients in the organization, so most use Roundcube 
exclusively.

> I'm using RC only and all day, no local mail client installed at all, 
> that
> may be a difference.

I also use RC exclusively, and have for more than three years now.

> And if all of your users should be using RC only and all day (which 
> would
> surprise me), how can you be sure that they do not experience any 
> session
> timeouts at all? Because your log files are telling you that, or just
> because they don't report anything? If the latter - well ... users, 
> you
> know? ;)

Trust me, my users are whiners. If there were timeouts, I'd know. But 
I've checked the logs to verify, no session timeouts.

> At least, there have been several reports of session timeouts from 
> several
> other users/administrators besides me here. So there seems to be an 
> issue.

I'm not trying to imply there's no problem, but simply stating that 
these issues are far from universal, which would lead me to think about 
your environment.

>> I've been personally been using the latest svn
>
> Well, that's not 0.7.2 stable then, right?

All of my normal users are on 0.7.2-stable, but I myself am currently 
testing the latest svn in preparation for roll-out once 0.8 goes stable.

> JFTR of this list as of today:
>
> Server-side:
> ------------
> - dedicated server i386/64bit under Debian GNU/Linux 6.0 (Squeeze)
> - Dovecot 1.2.15
> - Apache 2.2.16
> - PHP 5.3.3
> - All services running on the same machine, no encryption, no proxy
>
> Locally:
> --------
> Win7/64
> IE8

Both 0.7.2 and svn are hosted on the same server (RHEL5, Apache 2.2.3, 
PHP 5.3.3). IMAP is on a separate server (also RHEL5, sendmail, Dovecot 
1.1.4).

I'm testing mine against both Win7/32 & Mac OS10.7, using primarily 
Safari & Firefox (on both platforms).

--
Arne Berglund
System Administrator, Internet Services
Lane Education Service District
Eugene, OR
____________




More information about the users mailing list