[RCU] spell checker hangs

Alexander Pyhalov alp at rsu.ru
Wed Jun 11 10:53:51 CEST 2014


Hello.
On our roundcube installation I see the following error.
When I send message, roundcube hangs with status "Sending message" for 
several minutes. Then I receive "Request time out". However, the message 
is sent. It's related to spell checker. I see that after sending message 
our roundcube host opens connection to spell.roundcube.net (443 port) 
and they are talking for a second:

12:01:24.804884 IP webmail-test.58972 > plugins.roundcube.net.https: 
Flags [S], seq 3244734379, win 14600, options [mss 1460,sackOK,TS val 
3808005355 ecr 0,nop,wscale 7], length 0
12:01:24.868230 IP plugins.roundcube.net.https > webmail-test.58972: 
Flags [S.], seq 3698264996, ack 3244734380, win 14480, options [mss 
1460,sackOK,TS val 1331948192 ecr 3808005355,nop,wscale 6], length 0
12:01:24.868264 IP webmail-test.58972 > plugins.roundcube.net.https: 
Flags [.], ack 1, win 115, options [nop,nop,TS val 3808005418 ecr 
1331948192], length 0
12:01:24.869062 IP webmail-test.58972 > plugins.roundcube.net.https: 
Flags [P.], seq 1:349, ack 1, win 115, options [nop,nop,TS val 
3808005419 ecr 1331948192], length 348
12:01:24.932086 IP plugins.roundcube.net.https > webmail-test.58972: 
Flags [.], ack 349, win 243, options [nop,nop,TS val 1331948208 ecr 
3808005419], length 0
12:01:24.935464 IP plugins.roundcube.net.https > webmail-test.58972: 
Flags [.], seq 1:1449, ack 349, win 243, options [nop,nop,TS val 
1331948209 ecr 3808005419], length 1448
12:01:24.935492 IP webmail-test.58972 > plugins.roundcube.net.https: 
Flags [.], ack 1449, win 137, options [nop,nop,TS val 3808005485 ecr 
1331948209], length 0
12:01:24.935464 IP plugins.roundcube.net.https > webmail-test.58972: 
Flags [.], seq 1449:2897, ack 349, win 243, options [nop,nop,TS val 
1331948209 ecr 3808005419], length 1448
12:01:24.935508 IP webmail-test.58972 > plugins.roundcube.net.https: 
Flags [.], ack 2897, win 160, options [nop,nop,TS val 3808005485 ecr 
1331948209], length 0
12:01:24.935473 IP plugins.roundcube.net.https > webmail-test.58972: 
Flags [.], ack 349, win 243, options [nop,nop,TS val 1331948209 ecr 
3808005419], length 0
12:01:24.935478 IP plugins.roundcube.net.https > webmail-test.58972: 
Flags [P.], seq 2897:2975, ack 349, win 243, options [nop,nop,TS val 
1331948209 ecr 3808005419], length 78
12:01:24.935519 IP webmail-test.58972 > plugins.roundcube.net.https: 
Flags [.], ack 2975, win 160, options [nop,nop,TS val 3808005485 ecr 
1331948209], length 0
12:01:24.937478 IP webmail-test.58972 > plugins.roundcube.net.https: 
Flags [P.], seq 349:483, ack 2975, win 160, options [nop,nop,TS val 
3808005487 ecr 1331948209], length 134
12:01:25.001537 IP plugins.roundcube.net.https > webmail-test.58972: 
Flags [P.], seq 2975:3225, ack 483, win 260, options [nop,nop,TS val 
1331948226 ecr 3808005487], length 250
12:01:25.002056 IP webmail-test.58972 > plugins.roundcube.net.https: 
Flags [P.], seq 483:909, ack 3225, win 182, options [nop,nop,TS val 
3808005552 ecr 1331948226], length 426
12:01:25.101188 IP plugins.roundcube.net.https > webmail-test.58972: 
Flags [.], ack 909, win 277, options [nop,nop,TS val 1331948251 ecr 
3808005552], length 0

then connection hangs in ESTABLISHED state for several minutes.

How can I debug the issue?
I see this behavior on both production and test server. Production 
server was running Roundcube Webmail 1.0-rc for a year now. It seems 
that errors started to occur this Monday...
-- 
Best regards,
Alexander Pyhalov,
system administrator of Computer Center of Southern Federal University


More information about the users mailing list