[RCU] Unable to connect to server

webmaster webmaster at my-it-brain.de
Mon Jan 19 20:37:25 CET 2015


Hello users,

I'm using the roundcube webmailer and I'm trying to enable the
managesieve plugin. But I get the error message "Unable to connect to
server" and have no idea what's wrong.

Here are some information about my system environment:

Distributor ID:	Ubuntu
Description:	Ubuntu 14.04.1 LTS
Release:	14.04
Codename:	trusty
:~$ sudo netstat -tulpen
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address
State       User       Inode       PID/Program name
tcp        0      0 0.0.0.0:25              0.0.0.0:*
LISTEN      0          3102948964  1515/master
tcp        0      0 0.0.0.0:443             0.0.0.0:*
LISTEN      0          16378785    2059/nginx
tcp        0      0 0.0.0.0:4190            0.0.0.0:*
LISTEN      0          3097769441  544/dovecot
tcp        0      0 0.0.0.0:993             0.0.0.0:*
LISTEN      0          3097769517  544/dovecot
tcp        0      0 127.0.0.1:3306          0.0.0.0:*
LISTEN      115        3098328820  605/mysqld
tcp        0      0 0.0.0.0:587             0.0.0.0:*
LISTEN      0          3102949140  1515/master
tcp        0      0 0.0.0.0:143             0.0.0.0:*
LISTEN      0          3097769511  544/dovecot
tcp        0      0 0.0.0.0:80              0.0.0.0:*
LISTEN      0          16378780    2059/nginx
tcp        0      0 0.0.0.0:22              0.0.0.0:*
LISTEN      0          3097766721  547/sshd
tcp6       0      0 :::25                   :::*
LISTEN      0          3102948969  1515/master
tcp6       0      0 :::4190                 :::*
LISTEN      0          3097769446  544/dovecot
tcp6       0      0 :::993                  :::*
LISTEN      0          3097769520  544/dovecot
tcp6       0      0 :::587                  :::*
LISTEN      0          3102949154  1515/master
tcp6       0      0 :::143                  :::*
LISTEN      0          3097769514  544/dovecot
tcp6       0      0 :::22                   :::*
LISTEN      0          3097766741  547/sshd

As you can see, sieve is listening on port 4190 on localhost. In my
/usr/share/nginx/roundcube/plugins/managesieve/config.inc.php.dist the
following connection parameters are configured:

// managesieve server port. When empty the port will be determined
automatically
// using getservbyname() function, with 4190 as a fallback.
$config['managesieve_port'] = 4190;

// managesieve server address, default is localhost.
// Replacement variables supported in host name:
// %h - user's IMAP hostname
// %n - http hostname ($_SERVER['SERVER_NAME'])
// %d - domain (http hostname without the first part)
// For example %n = mail.domain.tld, %d = domain.tld
$config['managesieve_host'] = '127.0.0.1';

When I connect to the port 4190 I get the following connection:

:~$ telnet 127.0.0.1 4190
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.
"IMPLEMENTATION" "Dovecot (Ubuntu) Pigeonhole"
"SIEVE" "fileinto reject envelope encoded-character vacation subaddress
comparator-i;ascii-numeric relational regex imap4flags copy include
variables body enotify environment mailbox date ihave"
"NOTIFY" "mailto"
"SASL" "PLAIN LOGIN"
"STARTTLS"
"VERSION" "1.0"
OK "Dovecot (Ubuntu) ready."

I don't understand what's wrong here and appreciate your help.

Thanks in advance.
John


More information about the users mailing list