[RCU] Reply to own messages broken...?

Michael Heydekamp listuser at freexp.de
Tue Jun 16 18:57:18 CEST 2015


Hi,

just did set up some mail accounts for a new user and did realize that
replies to an own message are being sent to the own address of the original
sender rather than to the address of the original recipient.

This still works:
-----------------
1)
> From: Michael Heydekamp <michael at mydomain.de>
> Display name: Michael Heydekamp
> Email: michael at mydomain.de

This does not work:
-------------------
2)
> From: Michael Heydekamp <michael at mydomain.de>
> Display name: Michael Heydekamp xxxxxx - xxxxxxx xxx xxxxxxx
> Email: michael at mydomain.de

3)
> From: Michael Heydekamp xxxxxx - xxxxxxx xxx xxxxxxx <michael at mydomain.de>
> Display name: Michael Heydekamp xxxxxx - xxxxxxx xxx xxxxxxx
> Email: michael at mydomain.de

4)
> From: =?UTF-8?Q?Michael_Heydekamp_xxxxxx_-_xxxxxxx_xxx_xxxxxxx?=
>  <michael at mydomain.de>
> Display name: Michael Heydekamp
> Email: michael at mydomain.de

Where "Display name" and "Email" are the relevant entries under
Settings/Identities, and "From:" is the From header of the message.

According to Example 2) above, Roundcube seems to check for the display name
as well...? IMO, it shouldn't do that and check for the address only.

Example 3) is strange: Display names are identical, nonetheless the routine
fails. Is the display name too long?

Example 4): Not sure if folded headers are the problem here.

Fix appreciated, as the user in question did already send a few messages to
himself, relying on a working Reply-to-own-messages routine (and not
realizing the wrong recipient address).

Cheers,
-- 
Michael Heydekamp
Co-Admin freexp.de
Düsseldorf/Germany


More information about the users mailing list