[RCU] SMTP and IMAP/STARTTLS

Rich Lott itmanager at peopleandplanet.org
Wed Oct 11 16:37:20 CEST 2017


Hi

On my first issue: wanting to use different SMTP settings for different 
hosts, I've found this plugin: 
https://gitlab.com/kolab-roundcube-plugins/ude-login
which is not quite what I wanted but will do.

However, I'm still having problems with starttls. There's two situations 
where I need to check/fix STARTTLS

1. When roundcube accesses a remote IMAP server to fetch mail.

2. When roundcube accesses a remote SMTP server to send mail.


On 11/10/17 14:57, Reindl Harald wrote:
> it does always when the server offers TLS and frankly it does even on 
> 127.0.0.1 and then complain about certificte not machting - but why 
> don#t you see the TLS connection in your maillog on the smtp server?

Thanks, but in my situation I do not control either of the remote 
servers, so I cannot check their logs.


I enabled imap_debug on roundcube but it does not seem to be clear :

[11-Oct-2017 15:32:49 +0100]: <vgbmv43h> [50AA] S: * OK [CAPABILITY 
IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE IDLE *STARTTLS* 
AUTH=PLAIN] Dovecot ready.
[11-Oct-2017 15:32:49 +0100]: <vgbmv43h> [50AA] C: A0001 ID ("name" 
"Roundcube" "version" "1.3.0 " "php" "7.0.19-1" "os" "Linux" "command" 
"/?_task=mail&_action=refresh")
[11-Oct-2017 15:32:49 +0100]: <vgbmv43h> [50AA] S: * ID ("name" "Dovecot")
[11-Oct-2017 15:32:49 +0100]: <vgbmv43h> [50AA] S: A0001 OK ID completed.
[11-Oct-2017 15:32:49 +0100]: <vgbmv43h> [50AA] C: A0002 AUTHENTICATE 
PLAIN ****** [37]
[11-Oct-2017 15:32:49 +0100]: <vgbmv43h> [50AA] S: A0002 OK [CAPABILITY 
IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE IDLE SORT 
SORT=DISPLAY THREAD=REFERENCES THREAD=REFS THREAD=ORDEREDSUBJECT 
MULTIAPPEND URL-PARTIAL CATENATE UNSELECT CHILDREN NAMESPACE UIDPLUS 
LIST-EXTENDED I18NLEVEL=1 CONDSTORE QRESYNC ESEARCH ESORT SEARCHRES 
WITHIN CONTEXT=SEARCH LIST-STATUS BINARY MOVE] Logged in





I have enabled smtp_debug on roundcube. Here's the chat while SENDING to 
the SMTP server:


Send: EHLO (xxxxx removed xxxx)
Recv: 250-xxxxxx removed xxxxxx
Recv: 250-PIPELINING
Recv: 250-SIZE 30240000
Recv: 250-VRFY
Recv: 250-ETRN
Recv: 250-STARTTLS
Recv: 250-ENHANCEDSTATUSCODES
Recv: 250-8BITMIME
Recv: 250 DSN
Send: RSET
Recv: 530 5.7.0 Must issue a STARTTLS command first
Send: QUIT
Recv: 221 2.0.0 Bye

So it looks like RC is not sending STARTTLS back in response?

?


-- 
Rich

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.roundcube.net/pipermail/users/attachments/20171011/22a1b141/attachment.html>


More information about the users mailing list