[RCU] Roundcube Webmail 1.4.0 - Elastic released

Nuno Dias ndias at lip.pt
Mon Nov 18 15:06:40 CET 2019


 Hi,

 Ok, I found the problem and David helped, my problem was that I had

 $config['smtp_user'] = '%u'
 $config['smtp_pass'] = '%p'

 because I read "SMTP username (if required)", so I'm using port 25 and
doesn't requires authentication, so this will be ignored, and that is
not true, this will be used if set!

 The other problem when I tested it with tls and port 587 is the option

$config['smtp_conn_options'] = array( ...

was not set, and is necessary for tls to work.

Cheers,
Nuno

On Fri, 2019-11-15 at 15:44 +0000, David Carter wrote:
> On 2019-11-14 16:40, Nuno Dias wrote:
> > After upgrading to this new release the send mail stopped to work,
> > and
> > now, no matter what I configure in smtp variables (tls, or only
> > port
> > 25) I have always the same error.
> > 
> > SMTP Error: Authentication failure: SMTP server does not support
> > authentication
> 
> config/defaults.inc.php in 1.4.0 includes:
> 
> // SMTP username (if required) if you use %u as the username
> Roundcube
> // will use the current username for login
> $config['smtp_user'] = '%u';
> 
> // SMTP password (if required) if you use %p as the password
> Roundcube
> // will use the current user's password for login
> $config['smtp_pass'] = '%p';
> 
> while config/defaults.inc.php in 1.3.10 has:
> 
> config['smtp_user'] = '';
> $config['smtp_pass'] = '';
> 
> I suspect this is the source of your problems.
> 
-- 
Nuno Dias <ndias at lip.pt>
LIP
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 2835 bytes
Desc: not available
URL: <http://lists.roundcube.net/pipermail/users/attachments/20191118/d233c98f/attachment.bin>


More information about the users mailing list