[RCU] Roundcube: upgrade to 1.5 from 1.4

Aleksander Machniak alec at alec.pl
Tue Oct 19 18:23:15 CEST 2021


On 19.10.2021 17:32, Luciano Mannucci wrote:

> ERROR: Error in DDL upgrade 2020020101: [1071] Specified key was too
> long; max key length is 767 bytes
> All done.
> 
> It might require its own version of mysql, but I haven't seen anything
> about that in the requirenents. Is there any?

https://github.com/roundcube/roundcubemail/issues/8231

It's noted in the INSTALL and UPGRADING file

When using MySQL < 5.7.7 or MariaDB < 10.2.2 it is required to configure
the database engine with:
    innodb_large_prefix=true
    innodb_file_format=Barracuda

ps. try ON instead of true, if it does not work.

-- 
Aleksander Machniak
Kolab Groupware Developer        [https://kolab.org]
Roundcube Webmail Developer  [https://roundcube.net]
----------------------------------------------------
PGP: 19359DC1 # Blog: https://kolabian.wordpress.com


More information about the users mailing list