I know this will break backward compatybility, but I think we should unify names of hooks/events. So, what need to be changed:
Events: insertgroup group_add updategroup group_update removegroup group_delete insertrow message_add listupdate list_update selectfolder folder_select Hooks: create_user user_create kill_session session_destroy upload_attachment attachment_upload save_attachment attachment_save outgoing_message_headers message_outgoing_headers outgoing_message_body message_outgoing_body address_sources addressbooks_list get_address_book addressbook_get create_contact contact_create save_contact contact_save delete_contact contact_delete manage_folders folders_list save_preferences settings_save user_preferences settings_list list_prefs_sections settings_sections_list list_identities identities_list create_identity identity_create save_identity identity_save
Any way you can support both names between say 0.4 and 0.5? To give plugin authors a bit more time to change their plugins? Or is 0.4 not imminent?
Cor
List info: http://lists.roundcube.net/dev/
On 21.05.2010 10:45, Cor Bosman wrote:
Any way you can support both names between say 0.4 and 0.5?
We're after beta now, so this is proposed for 0.5, but sooner = better.
Changes in plugins will be not so complicated. For plugins backward compatibility, plugin authors could bind to both old and new names.
On Fri, 21 May 2010 10:28:51 +0200, "A.L.E.C" alec@alec.pl wrote:
I know this will break backward compatybility, but I think we should unify names of hooks/events. So, what need to be changed:
Old Name New Name
Events: insertgroup group_add updategroup group_update removegroup group_delete insertrow message_add listupdate list_update selectfolder folder_select Hooks: create_user user_create kill_session session_destroy upload_attachment attachment_upload save_attachment attachment_save outgoing_message_headers message_outgoing_headers outgoing_message_body message_outgoing_body address_sources addressbooks_list get_address_book addressbook_get create_contact contact_create save_contact contact_save delete_contact contact_delete manage_folders folders_list save_preferences settings_save user_preferences settings_list list_prefs_sections settings_sections_list list_identities identities_list create_identity identity_create save_identity identity_save
If you make this change, please think about to implement wrapper methods for old names.
List info: http://lists.roundcube.net/dev/
On Fri, May 21, 2010 at 10:45, Cor Bosman cor@xs4all.nl wrote:
Any way you can support both names between say 0.4 and 0.5? To give plugin authors a bit more time to change their plugins? Or is 0.4 not imminent?
This is mandatory for me. In order to provide backward compatibility the plugin_api class could maintain a mapping list and also call the "old" hooks.
Let's create a ticket for that and assign it to 0.5, OK?
~Thomas _______________________________________________ List info: http://lists.roundcube.net/dev/
On Fri, 21 May 2010 14:51:04 +0200, Thomas Bruederli roundcube@gmail.com wrote:
On Fri, May 21, 2010 at 10:45, Cor Bosman cor@xs4all.nl wrote:
Any way you can support both names between say 0.4 and 0.5? To give plugin authors a bit more time to change their plugins? Or is 0.4 not imminent?
This is mandatory for me. In order to provide backward compatibility the plugin_api class could maintain a mapping list and also call the "old" hooks.
Let's create a ticket for that and assign it to 0.5, OK?
~Thomas
If possible, it would be nice to log some sort of deprecation warning when plugins using the old names are loaded. Even better if they can be automatically converted.
-Albert
List info: http://lists.roundcube.net/dev/
On Fri, 21 May 2010 14:51:04 +0200, Thomas Bruederli roundcube@gmail.com wrote:
Let's create a ticket for that and assign it to 0.5, OK?
Ok, I'll do it. In meantime I think we can change at least three event names, because they are new in 0.4.
insertgroup group_add updategroup group_update removegroup group_delete